Old Kindles Require Update to Stay Alive

By Dianna Dilworth Comment

kindle1If you have a Kindle from 2012 or earlier, then you need to update your software by tomorrow to keep it functioning.

“Customers using an outdated software version on Kindle e-readers require an important software update by March 22, 2016 in order to continue to download Kindle books from the Cloud, access the Kindle Store, and use other Kindle services on their device,” Amazon explained on its site.

Follow this link for more details about which software is required for which devices.

Advertisement
Advertisement