Is Android Backward App Compatibility Important? No One Seems to Mind iPhone Apps Which Are Not Backward Compatible

I read this over on TechCrunch…

Android Backward Compatibility Talk Begins. This Is Starting To Sound Complicated

…and began thinking, “oh those poor Android end-users and developers.” Then, it occurred to me that most iPhone app descriptions in the iTunes App Store specifically state that they only work with the latest iPhone firmware. And, how many times have I run into an app that works fine on my iPhone 3G with 2.2.1 firmware only to find the same app does not work on my first generation iPod touch which also has the 2.2.1 firmware installed.

If anything, since the number of Android phone users is much smaller than the number of iPhone users, the move from Android 1.0/1.1 to 1.5 may be much less painful than iPhone firmware upgrades. Of course, I may have to eat my words in June after iPhone OS 3.0 is presumably released. All kind of app breakage may occur after that. Stay tuned…